[jetty-users] --exec in 7.6.0

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

[jetty-users] --exec in 7.6.0

Gergo Ertli
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo


_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Thomas Becker
Hi Gergo,

which operating system are you running on? On my box (macos) it works fine with your config. Even the newline between --exec and -Xmx1500m doesn't harm. I will try the same thing with the current release and report back how it worked out.

Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Thomas Becker
In reply to this post by Gergo Ertli
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.

Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Gergo Ertli
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Thomas Becker
Yes, it's broken. We're working on a fix and will release it asap.

On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Thomas Becker
In reply to this post by Gergo Ertli
Hi Gergo,

this is the bugzilla if you want to keep track of the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

Cheers,
Thomas

On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Gergo Ertli
Hi,

Thanks for the quick fix.

Gergo

On Mon, Jan 30, 2012 at 2:42 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

this is the bugzilla if you want to keep track of the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

Cheers,
Thomas


On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Joakim Erdfelt-9

A prelim fix for the ${jetty.home}/start.jar has been deployed to https://oss.sonatype.org/content/repositories/jetty-snapshots/org/eclipse/jetty/jetty-start/7.6.1-SNAPSHOT/ for those that want to test it.

We are currently testing it ourselves, but would like to share it with those involved in this thread early.

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 7:47 AM, Gergo Ertli <[hidden email]> wrote:
Hi,

Thanks for the quick fix.

Gergo


On Mon, Jan 30, 2012 at 2:42 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

this is the bugzilla if you want to keep track of the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

Cheers,
Thomas


On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Gergo Ertli
Maybe because of version mismatch (i did not check the source, nor know the algorithm), this snapshot start.jar did not include the 7.6.0 jars to the classpath, so it stops with a NoClassDefFound exception:

Could not find the main class: org.eclipse.jetty.xml.XmlConfiguration.  Program will exit.

For the test I kept all the 7.6.0 files, and replaced start.jar with the provided one.

Gergo

On Mon, Jan 30, 2012 at 5:24 PM, Joakim Erdfelt <[hidden email]> wrote:

A prelim fix for the ${jetty.home}/start.jar has been deployed to https://oss.sonatype.org/content/repositories/jetty-snapshots/org/eclipse/jetty/jetty-start/7.6.1-SNAPSHOT/ for those that want to test it.

We are currently testing it ourselves, but would like to share it with those involved in this thread early.

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 7:47 AM, Gergo Ertli <[hidden email]> wrote:
Hi,

Thanks for the quick fix.

Gergo


On Mon, Jan 30, 2012 at 2:42 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

this is the bugzilla if you want to keep track of the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

Cheers,
Thomas


On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Joakim Erdfelt-9
Gergo, good catch, the internal start.config has references to 7.6.1 versions via the $(version) expansion.
Working on fix for that and another one related to spaces in paths on unix/linux/osx (shockingly not windows) as well.

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 9:39 AM, Gergo Ertli <[hidden email]> wrote:
Maybe because of version mismatch (i did not check the source, nor know the algorithm), this snapshot start.jar did not include the 7.6.0 jars to the classpath, so it stops with a NoClassDefFound exception:

Could not find the main class: org.eclipse.jetty.xml.XmlConfiguration.  Program will exit.

For the test I kept all the 7.6.0 files, and replaced start.jar with the provided one.

Gergo


On Mon, Jan 30, 2012 at 5:24 PM, Joakim Erdfelt <[hidden email]> wrote:

A prelim fix for the ${jetty.home}/start.jar has been deployed to https://oss.sonatype.org/content/repositories/jetty-snapshots/org/eclipse/jetty/jetty-start/7.6.1-SNAPSHOT/ for those that want to test it.

We are currently testing it ourselves, but would like to share it with those involved in this thread early.

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 7:47 AM, Gergo Ertli <[hidden email]> wrote:
Hi,

Thanks for the quick fix.

Gergo


On Mon, Jan 30, 2012 at 2:42 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

this is the bugzilla if you want to keep track of the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

Cheers,
Thomas


On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Joakim Erdfelt-9
An updated SNAPSHOT was pushed for the $(version) issue.

You should be able to override the internal "jetty.version" now with a system property.

[joakim@lapetus jetty-distribution-7.6.0.v20120127]$ cp ~/.m2/repository/org/eclipse/jetty/jetty-start/7.6.1-SNAPSHOT/jetty-start-7.6.1-SNAPSHOT.jar start.jar

[joakim@lapetus jetty-distribution-7.6.0.v20120127]$ java -Djetty.version=7.6.0.v20120127 -jar start.jar2012-01-30 10:00:20.400:INFO:oejs.Server:jetty-7.6.0.v20120127
2012-01-30 10:00:20.418:INFO:oejdp.ScanningAppProvider:Deployment monitor /home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/webapps at interval 1
2012-01-30 10:00:20.421:INFO:oejdp.ScanningAppProvider:Deployment monitor /home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/contexts at interval 1
2012-01-30 10:00:20.423:INFO:oejd.DeploymentManager:Deployable added: /home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/contexts/javadoc.xml
2012-01-30 10:00:20.448:INFO:oejsh.ContextHandler:started o.e.j.s.h.ContextHandler{/javadoc,file:/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/javadoc/}
2012-01-30 10:00:20.449:INFO:oejd.DeploymentManager:Deployable added: /home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/contexts/test.xml
2012-01-30 10:00:20.484:INFO:oejw.WebInfConfiguration:Extract jar:file:/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/webapps/test.war!/ to /tmp/jetty-0.0.0.0-8080-test.war-_-any-/webapp
2012-01-30 10:00:20.868:INFO:oejsh.ContextHandler:started o.e.j.w.WebAppContext{/,file:/tmp/jetty-0.0.0.0-8080-test.war-_-any-/webapp/},/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/webapps/test.war
2012-01-30 10:00:20.963:INFO:oejs.TransparentProxy:TransparentProxy @ /javadoc-proxy to http://download.eclipse.org/jetty/stable-7/apidocs
2012-01-30 10:00:20.976:INFO:oejs.AbstractConnector:Started SelectChannelConnector@0.0.0.0:8080
^C2012-01-30 10:00:22.487:INFO:oejs.Server:Graceful shutdown SelectChannelConnector@0.0.0.0:8080
2012-01-30 10:00:22.488:INFO:oejs.Server:Graceful shutdown o.e.j.s.h.ContextHandler{/javadoc,file:/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/javadoc/}
2012-01-30 10:00:22.488:INFO:oejs.Server:Graceful shutdown o.e.j.w.WebAppContext{/,file:/tmp/jetty-0.0.0.0-8080-test.war-_-any-/webapp/},/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/webapps/test.war
2012-01-30 10:00:23.579:INFO:oejsl.ELContextCleaner:javax.el.BeanELResolver purged
2012-01-30 10:00:23.579:INFO:oejsh.ContextHandler:stopped o.e.j.w.WebAppContext{/,file:/tmp/jetty-0.0.0.0-8080-test.war-_-any-/webapp/},/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/webapps/test.war
2012-01-30 10:00:23.584:INFO:oejsh.ContextHandler:stopped o.e.j.s.h.ContextHandler{/javadoc,file:/home/joakim/code/intalio/distros/jetty-distribution-7.6.0.v20120127/javadoc/}
[joakim@

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 9:51 AM, Joakim Erdfelt <[hidden email]> wrote:
Gergo, good catch, the internal start.config has references to 7.6.1 versions via the $(version) expansion.
Working on fix for that and another one related to spaces in paths on unix/linux/osx (shockingly not windows) as well.

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 9:39 AM, Gergo Ertli <[hidden email]> wrote:
Maybe because of version mismatch (i did not check the source, nor know the algorithm), this snapshot start.jar did not include the 7.6.0 jars to the classpath, so it stops with a NoClassDefFound exception:

Could not find the main class: org.eclipse.jetty.xml.XmlConfiguration.  Program will exit.

For the test I kept all the 7.6.0 files, and replaced start.jar with the provided one.

Gergo


On Mon, Jan 30, 2012 at 5:24 PM, Joakim Erdfelt <[hidden email]> wrote:

A prelim fix for the ${jetty.home}/start.jar has been deployed to https://oss.sonatype.org/content/repositories/jetty-snapshots/org/eclipse/jetty/jetty-start/7.6.1-SNAPSHOT/ for those that want to test it.

We are currently testing it ourselves, but would like to share it with those involved in this thread early.

--
Joakim Erdfelt

(the people behind jetty and cometd)



On Mon, Jan 30, 2012 at 7:47 AM, Gergo Ertli <[hidden email]> wrote:
Hi,

Thanks for the quick fix.

Gergo


On Mon, Jan 30, 2012 at 2:42 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

this is the bugzilla if you want to keep track of the issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

Cheers,
Thomas


On 1/30/12 1:23 PM, Gergo Ertli wrote:
Hi,

It worked before 7.6. I tested 7.6.0 on Windows and Linux, and both appear to be broken.

Gergo

On Mon, Jan 30, 2012 at 1:14 PM, Thomas Becker <[hidden email]> wrote:
Hi Gergo,

I can confirm that this is broken for the current release. I will investigate on this and try to get this fixed asap.


Cheers,
Thomas

On 1/30/12 1:01 PM, Gergo Ertli wrote:
Hi,

Jetty does not generate the dry-run command correctly anymore.

I'm using start.ini to specify JVM flags. Here is is small example:

--exec

-Xmx1500m
-Xmn500m
......

The java -jar start.jar returns with an error. Asking for a dry run reveals the problem: the generated command string is

/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java-Xmx1500m-Xmn500m................

Spaces are missing between the JVM arguments.


Did something change here, am I doing something wrong? 

Best regards,
Gergo



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users

-- 
thomas becker
[hidden email]

http://webtide.com / http://intalio.com
(the folks behind jetty and cometd)

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users



_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users




_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Gergo Ertli
Great, thanks. It works on Windows. I'll test it on Linux soon.

On Mon, Jan 30, 2012 at 6:03 PM, Joakim Erdfelt <[hidden email]> wrote:
-Djetty.version=7.6.0.v20120127


_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] --exec in 7.6.0

Cemo
In reply to this post by Gergo Ertli
Hi,

I would like to share another problem here is that when I was trying to run jetty.sh. It raises:

syntax error near unexpected token `"$XMLFILE"'

At the beginning I thought it is related to this issue but then would like to share.

Thanks

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users