[jetty-users] Migrating from 7.5.4 to 8.1.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[jetty-users] Migrating from 7.5.4 to 8.1.0

Jeff Palmer
Installed 8.1.0 with a system with 7.5.4 .  Made similar changes to the .xml's & keystore and copied servlets. changed symbolic link to point to 8.1.0.  Things run, but all logging is written to start.log.  Nothing is in 2012_02_13.stderrout.log

The bigger problem is as soon as start.ini has any java options uncommented start fails.  For the simplest of examples uncomment --exec & -Xmx30000m, and this is the error in start.log:

java.io.IOException: Cannot run program "/opt/jre1.7.0_01/bin/java-Xmx30000m": error=2, No such file or directory
        at java.lang.ProcessBuilder.start(Unknown Source)
        at java.lang.Runtime.exec(Unknown Source)
        at java.lang.Runtime.exec(Unknown Source)
        at java.lang.Runtime.exec(Unknown Source)
        at org.eclipse.jetty.start.Main.start(Main.java:552)
        at org.eclipse.jetty.start.Main.main(Main.java:82)
Caused by: java.io.IOException: error=2, No such file or directory
        at java.lang.UNIXProcess.forkAndExec(Native Method)
        at java.lang.UNIXProcess.<init>(Unknown Source)
        at java.lang.ProcessImpl.start(Unknown Source)
        ... 6 more


There is no jar in the command.  Is it me or is there a problem?

Regards,

Jeff Palmer

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] Migrating from 7.5.4 to 8.1.0

Jesse McConnell
Check out: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

cheers,
jesse

--
jesse mcconnell
[hidden email]



On Mon, Feb 13, 2012 at 14:58, Jeff Palmer <[hidden email]> wrote:

> Installed 8.1.0 with a system with 7.5.4 .  Made similar changes to the
> .xml's & keystore and copied servlets. changed symbolic link to point to
> 8.1.0.  Things run, but all logging is written to start.log.  Nothing is in
> 2012_02_13.stderrout.log
>
> The bigger problem is as soon as start.ini has any java options uncommented
> start fails.  For the simplest of examples uncomment --exec & -Xmx30000m,
> and this is the error in start.log:
>
> java.io.IOException: Cannot run program
> "/opt/jre1.7.0_01/bin/java-Xmx30000m": error=2, No such file or directory
>         at java.lang.ProcessBuilder.start(Unknown Source)
>         at java.lang.Runtime.exec(Unknown Source)
>         at java.lang.Runtime.exec(Unknown Source)
>         at java.lang.Runtime.exec(Unknown Source)
>         at org.eclipse.jetty.start.Main.start(Main.java:552)
>         at org.eclipse.jetty.start.Main.main(Main.java:82)
> Caused by: java.io.IOException: error=2, No such file or directory
>         at java.lang.UNIXProcess.forkAndExec(Native Method)
>         at java.lang.UNIXProcess.<init>(Unknown Source)
>         at java.lang.ProcessImpl.start(Unknown Source)
>         ... 6 more
>
>
> There is no jar in the command.  Is it me or is there a problem?
>
> Regards,
>
> Jeff Palmer
>
> _______________________________________________
> jetty-users mailing list
> [hidden email]
> https://dev.eclipse.org/mailman/listinfo/jetty-users
>
_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-users] Migrating from 7.5.4 to 8.1.0

Jeff Palmer
In reply to this post by Jeff Palmer
Thanks,  I can wait a week for a do over.  What about the all output in start.log part?  I re-checked my changes to jetty-logging.xml.  There is not much there.  I set the first arg to true, which I think keeps everything in one file per day, incase of restart.  The next to 30, for 30 days. Finally, set timezone to EST.  Bugzilla did not come up with anything for a search on 'start.log"


----- Original Message -----
From: [hidden email]
To: [hidden email]
Sent: Mon, February 13, 2012, 4:22 PM
Subject: Re: [jetty-users] Migrating from 7.5.4 to 8.1.0

Check out: https://bugs.eclipse.org/bugs/show_bug.cgi?id=370120

cheers,
jesse

--
jesse mcconnell
[hidden email]



On Mon, Feb 13, 2012 at 14:58, Jeff Palmer wrote:
> Installed 8.1.0 with a system with 7.5.4 .  Made similar changes to the
> .xml's & keystore and copied servlets. changed symbolic link to point to
> 8.1.0.  Things run, but all logging is written to start.log.  Nothing is in
> 2012_02_13.stderrout.log
>
> The bigger problem is as soon as start.ini has any java options uncommented
> start fails.  For the simplest of examples uncomment --exec & -Xmx30000m,
> and this is the error in start.log:
>
> java.io.IOException: Cannot run program
> "/opt/jre1.7.0_01/bin/java-Xmx30000m": error=2, No such file or directory
>         at java.lang.ProcessBuilder.start(Unknown Source)
>         at java.lang.Runtime.exec(Unknown Source)
>         at java.lang.Runtime.exec(Unknown Source)
>         at java.lang.Runtime.exec(Unknown Source)
>         at org.eclipse.jetty.start.Main.start(Main.java:552)
>         at org.eclipse.jetty.start.Main.main(Main.java:82)
> Caused by: java.io.IOException: error=2, No such file or directory
>         at java.lang.UNIXProcess.forkAndExec(Native Method)
>         at java.lang.UNIXProcess.(Unknown Source)
>         at java.lang.ProcessImpl.start(Unknown Source)
>         ... 6 more
>
>
> There is no jar in the command.  Is it me or is there a problem?
>
> Regards,
>
> Jeff Palmer
>
> _______________________________________________
> jetty-users mailing list
> [hidden email]
> https://dev.eclipse.org/mailman/listinfo/jetty-users
>

_______________________________________________
jetty-users mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/jetty-users