[jetty-dev] SharedBlockingCallback:Thread-X: Blocker not complete Blocker

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[jetty-dev] SharedBlockingCallback:Thread-X: Blocker not complete Blocker

Emily
We have upgraded from 8.16 to 9.2.17 and our application hangs once in a
while. When I inspect the log the QTP Thread are suck and waiting for
SharedBlockingCallback.

I have read that this issues was fix on later version of Jetty 9.3.x but
migrating to version 9.3.x requires us to upgrade our java to 1.8 which
would likely yield into redesigning the whole system since this system was
first build from 1.5 and we were able to upgrade it up to 1.7. Is the latest
version of 9.2.x as of now (9.2.22) include the fix for the
SharedBlockingCallback$Blcker?



--
Sent from: http://jetty.4.x6.nabble.com/Jetty-Dev-f3247346.html
_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] SharedBlockingCallback:Thread-X: Blocker not complete Blocker

Greg Wilkins

Emily,

I'm surprised you are having issues with SharedBlockingCallback in 9.2.x, as most of the problems we had with that were in 9.3.x releases.

Either way, it is going to be very difficult for us to give any open source support on 9.2.x releases, as they are very old. But 9.2.22 is the latest on that series, so it is the best one to try.

Note that running any public application on java 1.7 could be insecure as that is end-of-life and there are no longer any security updates, specially for SSL where there are known exploits.

regards



On 26 October 2017 at 13:30, Emily <[hidden email]> wrote:
We have upgraded from 8.16 to 9.2.17 and our application hangs once in a
while. When I inspect the log the QTP Thread are suck and waiting for
SharedBlockingCallback.

I have read that this issues was fix on later version of Jetty 9.3.x but
migrating to version 9.3.x requires us to upgrade our java to 1.8 which
would likely yield into redesigning the whole system since this system was
first build from 1.5 and we were able to upgrade it up to 1.7. Is the latest
version of 9.2.x as of now (9.2.22) include the fix for the
SharedBlockingCallback$Blcker?



--
Sent from: http://jetty.4.x6.nabble.com/Jetty-Dev-f3247346.html
_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev



--

_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] SharedBlockingCallback:Thread-X: Blocker not complete Blocker

Emily
Thanks Greg,

Yes, based from what I have read, this problem was fixed on later version of 9.3.x but I am not sure if this was ported back to 9.2.x. We are already planning to redesign and recreate the system since upgrading it to Java 1.8 will cause a major overhaul of the architecture. 

But right now while we are need to find a way to resolve the issue since the redesign cannot be done immediately. I might as well try the 9.2.22 but I just want to know if there are other who have experienced this problem and resolved this by upgrading to the latest 9.2.x release.

Regards,
Emily

On Thu, Oct 26, 2017 at 10:37 AM, Greg Wilkins <[hidden email]> wrote:

Emily,

I'm surprised you are having issues with SharedBlockingCallback in 9.2.x, as most of the problems we had with that were in 9.3.x releases.

Either way, it is going to be very difficult for us to give any open source support on 9.2.x releases, as they are very old. But 9.2.22 is the latest on that series, so it is the best one to try.

Note that running any public application on java 1.7 could be insecure as that is end-of-life and there are no longer any security updates, specially for SSL where there are known exploits.

regards



On 26 October 2017 at 13:30, Emily <[hidden email]> wrote:
We have upgraded from 8.16 to 9.2.17 and our application hangs once in a
while. When I inspect the log the QTP Thread are suck and waiting for
SharedBlockingCallback.

I have read that this issues was fix on later version of Jetty 9.3.x but
migrating to version 9.3.x requires us to upgrade our java to 1.8 which
would likely yield into redesigning the whole system since this system was
first build from 1.5 and we were able to upgrade it up to 1.7. Is the latest
version of 9.2.x as of now (9.2.22) include the fix for the
SharedBlockingCallback$Blcker?



--
Sent from: http://jetty.4.x6.nabble.com/Jetty-Dev-f3247346.html
_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev



--

_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev