[jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

[jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

upendar devu
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

Greg Wilkins
gregw@Tile440: ~/src/jetty-9.4.x/apache-jsp ((jetty-9.4.5.v20170502))
[2014] mvn dependency:tree
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Jetty :: Apache JSP Implementation 9.4.5.v20170502
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-dependency-plugin:3.0.0:tree (default-cli) @ apache-jsp ---
[INFO] org.eclipse.jetty:apache-jsp:jar:9.4.5.v20170502
[INFO] +- org.eclipse.jetty:jetty-util:jar:9.4.5.v20170502:compile
[INFO] +- org.eclipse.jetty.toolchain:jetty-schemas:jar:3.1:compile
[INFO] +- javax.servlet:javax.servlet-api:jar:3.1.0:compile
[INFO] +- org.mortbay.jasper:apache-jsp:jar:8.5.9.1:compile
[INFO] |  \- org.mortbay.jasper:apache-el:jar:8.5.9.1:compile
[INFO] +- org.eclipse.jdt.core.compiler:ecj:jar:4.4.2:compile
[INFO] +- org.eclipse.jetty:jetty-servlet:jar:tests:9.4.5.v20170502:test
[INFO] |  \- org.eclipse.jetty:jetty-security:jar:9.4.5.v20170502:test
[INFO] |     \- org.eclipse.jetty:jetty-server:jar:9.4.5.v20170502:test
[INFO] |        +- org.eclipse.jetty:jetty-http:jar:9.4.5.v20170502:test
[INFO] |        \- org.eclipse.jetty:jetty-io:jar:9.4.5.v20170502:test
[INFO] +- org.eclipse.jetty:jetty-servlet:jar:9.4.5.v20170502:test
[INFO] \- org.eclipse.jetty.toolchain:jetty-test-helper:jar:4.0:test
[INFO]    +- junit:junit:jar:4.12:test
[INFO]    |  \- org.hamcrest:hamcrest-core:jar:1.3:test
[INFO]    \- org.hamcrest:hamcrest-library:jar:1.3:test
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.905 s
[INFO] Finished at: 2017-05-30T21:21:44+02:00
[INFO] Final Memory: 22M/407M
[INFO] ------------------------------------------------------------------------


On 30 May 2017 at 20:40, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev



--

_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

Joakim Erdfelt-8
In reply to this post by upendar devu
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

upendar devu
Thanks for quick response. I will look into it.

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

upendar devu
In reply to this post by Greg Wilkins
Thanks for quick response and sharing tree structure. I will look into it.

On Tue, May 30, 2017 at 3:22 PM, Greg Wilkins <[hidden email]> wrote:
gregw@Tile440: ~/src/jetty-9.4.x/apache-jsp ((jetty-9.4.5.v20170502))
[2014] mvn dependency:tree
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Jetty :: Apache JSP Implementation 9.4.5.v20170502
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-dependency-plugin:3.0.0:tree (default-cli) @ apache-jsp ---
[INFO] org.eclipse.jetty:apache-jsp:jar:9.4.5.v20170502
[INFO] +- org.eclipse.jetty:jetty-util:jar:9.4.5.v20170502:compile
[INFO] +- org.eclipse.jetty.toolchain:jetty-schemas:jar:3.1:compile
[INFO] +- javax.servlet:javax.servlet-api:jar:3.1.0:compile
[INFO] +- org.mortbay.jasper:apache-jsp:jar:8.5.9.1:compile
[INFO] |  \- org.mortbay.jasper:apache-el:jar:8.5.9.1:compile
[INFO] +- org.eclipse.jdt.core.compiler:ecj:jar:4.4.2:compile
[INFO] +- org.eclipse.jetty:jetty-servlet:jar:tests:9.4.5.v20170502:test
[INFO] |  \- org.eclipse.jetty:jetty-security:jar:9.4.5.v20170502:test
[INFO] |     \- org.eclipse.jetty:jetty-server:jar:9.4.5.v20170502:test
[INFO] |        +- org.eclipse.jetty:jetty-http:jar:9.4.5.v20170502:test
[INFO] |        \- org.eclipse.jetty:jetty-io:jar:9.4.5.v20170502:test
[INFO] +- org.eclipse.jetty:jetty-servlet:jar:9.4.5.v20170502:test
[INFO] \- org.eclipse.jetty.toolchain:jetty-test-helper:jar:4.0:test
[INFO]    +- junit:junit:jar:4.12:test
[INFO]    |  \- org.hamcrest:hamcrest-core:jar:1.3:test
[INFO]    \- org.hamcrest:hamcrest-library:jar:1.3:test
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.905 s
[INFO] Finished at: 2017-05-30T21:21:44+02:00
[INFO] Final Memory: 22M/407M
[INFO] ------------------------------------------------------------------------


On 30 May 2017 at 20:40, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev



--

_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

upendar devu
In reply to this post by Joakim Erdfelt-8
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

Joakim Erdfelt-8
Yes, Jetty 8.x is EOL (End of Life).


Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:00 PM, upendar devu <[hidden email]> wrote:
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

upendar devu
Thank you,  I could not find migration docs from 8 to 9.  could you able to share me if you have any migration docs from 8 to 9 version  that would help to save time for migration work analysis.

On Tue, May 30, 2017 at 4:02 PM, Joakim Erdfelt <[hidden email]> wrote:
Yes, Jetty 8.x is EOL (End of Life).


Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:00 PM, upendar devu <[hidden email]> wrote:
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

Joakim Erdfelt-8
You would need migration docs for 8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

Reminder: Jetty versioning is <servlet_support>.<major>.<minor>

You are doing the equivalent of upgrading from Windows 95 -> 98 -> ME -> XP -> Windows 8 -> Windows 10

You'll have to dig into the documentation at each major version, look at the section you are interested in, and see if there is "changes in" type sections that are relevant to you.

Example:

Documentation links to previous versions:

Note: for the older releases, the documentation you are looking for, might already been archived.

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:12 PM, upendar devu <[hidden email]> wrote:
Thank you,  I could not find migration docs from 8 to 9.  could you able to share me if you have any migration docs from 8 to 9 version  that would help to save time for migration work analysis.

On Tue, May 30, 2017 at 4:02 PM, Joakim Erdfelt <[hidden email]> wrote:
Yes, Jetty 8.x is EOL (End of Life).


Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:00 PM, upendar devu <[hidden email]> wrote:
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

Greg Wilkins
Note that one big change in Jetty since 8 is that the module system has become more important.

So unless you have heavily used the internal APIs of jetty, it is probably best to not port your configuration, but rather start fresh with a distribution of jetty-9.4, read the doco about how to configure a JETTY_BASE directory, add the modules you think you need, then deploy your app and see what breaks.

If it is an embedded application with lots of calls to the API, the you'd probably be best to post a summary of the broken APIs that you are using and we can suggest where to look.

regards


On 30 May 2017 at 22:23, Joakim Erdfelt <[hidden email]> wrote:
You would need migration docs for 8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

Reminder: Jetty versioning is <servlet_support>.<major>.<minor>

You are doing the equivalent of upgrading from Windows 95 -> 98 -> ME -> XP -> Windows 8 -> Windows 10

You'll have to dig into the documentation at each major version, look at the section you are interested in, and see if there is "changes in" type sections that are relevant to you.

Example:

Documentation links to previous versions:

Note: for the older releases, the documentation you are looking for, might already been archived.

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:12 PM, upendar devu <[hidden email]> wrote:
Thank you,  I could not find migration docs from 8 to 9.  could you able to share me if you have any migration docs from 8 to 9 version  that would help to save time for migration work analysis.

On Tue, May 30, 2017 at 4:02 PM, Joakim Erdfelt <[hidden email]> wrote:
Yes, Jetty 8.x is EOL (End of Life).


Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:00 PM, upendar devu <[hidden email]> wrote:
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev



--

_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

Chris Walker
In reply to this post by Joakim Erdfelt-8
It's worth noting we do not have dedicated migration guides written for each major version at the current time. We have one for migrating from 9.3.x to 9.4.0, and it is something we plan on doing going forward. As Joakim stated, there are countless changes that have been made between 8.1.4 and 9.4.5 and a single guide would likely be volumes thick.

Best,
Chris

On Tue, May 30, 2017 at 4:23 PM, Joakim Erdfelt <[hidden email]> wrote:
You would need migration docs for 8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

Reminder: Jetty versioning is <servlet_support>.<major>.<minor>

You are doing the equivalent of upgrading from Windows 95 -> 98 -> ME -> XP -> Windows 8 -> Windows 10

You'll have to dig into the documentation at each major version, look at the section you are interested in, and see if there is "changes in" type sections that are relevant to you.

Example:

Documentation links to previous versions:

Note: for the older releases, the documentation you are looking for, might already been archived.

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:12 PM, upendar devu <[hidden email]> wrote:
Thank you,  I could not find migration docs from 8 to 9.  could you able to share me if you have any migration docs from 8 to 9 version  that would help to save time for migration work analysis.

On Tue, May 30, 2017 at 4:02 PM, Joakim Erdfelt <[hidden email]> wrote:
Yes, Jetty 8.x is EOL (End of Life).


Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:00 PM, upendar devu <[hidden email]> wrote:
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev
Reply | Threaded
Open this post in threaded view
|

Re: [jetty-dev] Jetty migration from 8.1.4 to 9.4.5 -- Need Jetty-jsp version

upendar devu
that makes sense , we will go through each major version that would makes more transparent on the changes.

Thanks

On Tue, May 30, 2017 at 4:31 PM, Chris Walker <[hidden email]> wrote:
It's worth noting we do not have dedicated migration guides written for each major version at the current time. We have one for migrating from 9.3.x to 9.4.0, and it is something we plan on doing going forward. As Joakim stated, there are countless changes that have been made between 8.1.4 and 9.4.5 and a single guide would likely be volumes thick.

Best,
Chris

On Tue, May 30, 2017 at 4:23 PM, Joakim Erdfelt <[hidden email]> wrote:
You would need migration docs for 8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

Reminder: Jetty versioning is <servlet_support>.<major>.<minor>

You are doing the equivalent of upgrading from Windows 95 -> 98 -> ME -> XP -> Windows 8 -> Windows 10

You'll have to dig into the documentation at each major version, look at the section you are interested in, and see if there is "changes in" type sections that are relevant to you.

Example:

Documentation links to previous versions:

Note: for the older releases, the documentation you are looking for, might already been archived.

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:12 PM, upendar devu <[hidden email]> wrote:
Thank you,  I could not find migration docs from 8 to 9.  could you able to share me if you have any migration docs from 8 to 9 version  that would help to save time for migration work analysis.

On Tue, May 30, 2017 at 4:02 PM, Joakim Erdfelt <[hidden email]> wrote:
Yes, Jetty 8.x is EOL (End of Life).


Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 1:00 PM, upendar devu <[hidden email]> wrote:
Its stated in the Jetty document that 8.1.4 is deprecated, does it mean that we should upgrade to latest version ? 

On Tue, May 30, 2017 at 3:23 PM, Joakim Erdfelt <[hidden email]> wrote:
That's a lot of major version upgrades you got there.

8.1 -> 9.0 -> 9.1 -> 9.2 -> 9.3 -> 9.4

We transitioned from glassfish jasper, to a period where we supported glassfish jasper and apache jasper, to only supporting apache-jasper.

You'll probably need the apache-jsp artifact.


Good luck,

Joakim Erdfelt / [hidden email]

On Tue, May 30, 2017 at 11:40 AM, upendar devu <[hidden email]> wrote:
we are upgrading Jetty version from 8.1.4 to latest stable version 9.4.5.


We are using below libraries and also listed its maven dependencies. We could not able to find jetty-jsp  with 9.4.5 version. 

Could you please let me know which version of jetty-jsp we need to use ?

Thanks



-  jetty-xml-8.1.4.v20120524.jar
- jetty-webapp-8.1.4.v20120524.jar
- jetty-servlet-8.1.4.v20120524.jar
- jetty-security-8.1.4.v20120524.jar
- jetty-continuation-8.1.4.v20120524.jar
- jetty-util-8.1.4.v20120524.jar
- jetty-server-8.1.4.v20120524.jar
- jetty-io-8.1.4.v20120524.jar
- jetty-http-8.1.4.v20120524.jar
- jetty-client-8.1.4.v20120524.jar
- jetty-jsp-8.1.4.v20120524.jar


<jetty.version>8.1.4.v20120524</jetty.version>


<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-jsp</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-client</artifactId>
<version>${jetty.version}</version>
<scope>${default.dependency.scope}</scope>
</dependency>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-jspc-maven-plugin</artifactId>
<version>${jetty.version}</version>
<executions>
<execution>
<id>jspc</id>
<goals>
<goal>jspc</goal>
</goals>
<configuration>
<packageRoot>org.apache.jsp</packageRoot>
</configuration>
</execution>
</executions>
 </plugin>


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev


_______________________________________________
jetty-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-dev