error maven jetty:run

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

error maven jetty:run

RJANAPA
This post has NOT been accepted by the mailing list yet.
Hi

I am getting the following errors while trying to run maven jetty:run in UNIX environment.

It runs without any errors on my local windows environment where I have JDK 1.6.0_31 installed but the same command fails in UNIX environment.

-bash-3.2$ /nfs/rh4-linux/java/apps/maven1.0/bin/maven jetty:run
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0

Attempting to download org.mortbay.jetty-4.2.17.jar.
WARNING: Failed to download org.mortbay.jetty-4.2.17.jar.
Attempting to download servletapi-2.3.jar.
WARNING: Failed to download servletapi-2.3.jar.
Attempting to download jasper-compiler-4.0.4.jar.
WARNING: Failed to download jasper-compiler-4.0.4.jar.
Attempting to download jasper-runtime-4.0.4.jar.
WARNING: Failed to download jasper-runtime-4.0.4.jar.
Attempting to download commons-jelly-tags-xml-20030211.142705.jar.
WARNING: Failed to download commons-jelly-tags-xml-20030211.142705.jar.
The build cannot continue because of the following unsatisfied dependencies:

org.mortbay.jetty-4.2.17.jar (try downloading from http://jetty.mortbay.org)
servletapi-2.3.jar
jasper-compiler-4.0.4.jar
jasper-runtime-4.0.4.jar
commons-jelly-tags-xml-20030211.142705.jar

Total time: 2 seconds
Finished at: Wed May 22 14:29:46 EDT 2013

-bash-3.2$

Here is my plugins part of my pom.xml

              <plugins>

                        <plugin>
                                <groupId>org.apache.maven.plugins</groupId>
                                <artifactId>maven-compiler-plugin</artifactId>
                                <version>2.3.2</version>
                                <configuration>
                                        <source>1.6</source>
                                        <target>1.6</target>
                                        <skipTests>true</skipTests>
                                </configuration>
                        </plugin>

                        <plugin>
                                <groupId>org.apache.maven.plugins</groupId>
                                <artifactId>maven-surefire-plugin</artifactId>
                                <version>2.7.2</version>
                                <configuration>
                                        <systemPropertyVariables>
                                                <tapestry.execution-mode>Qa</tapestry.execution-mode>
                                        </systemPropertyVariables>
                                </configuration>
                        </plugin>

                       

                        <plugin>
                                <groupId>org.mortbay.jetty</groupId>
                                <artifactId>jetty-maven-plugin</artifactId>
                        </plugin>
        </plugins>

Thanks