Upgrade 9.4.6.v20170531 -> 9.4.8.v20171121:

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade 9.4.6.v20170531 -> 9.4.8.v20171121:

Alexander Farber
Hello,

after upgrading from Jetty version 9.4.6.v20170531 to 9.4.8.v20171121 I unfortunately see the following errors when starting it on CentOS Linux 7 by the command

/usr/bin/java -Djdbc.drivers=org.postgresql.Driver -jar /usr/share/java/jetty-distribution-9.4.8.v20171121/start.jar jetty.home=/usr/share/java/jetty-distribution-9.4.8.v20171121 jetty.base=/var/www/jetty-base jetty.http.host=127.0.0.1

Mär 05 10:13:18 www systemd[1]: Starting Jetty...
Mär 05 10:13:19 www java[1083]: 2018-03-05 10:13:19.330:INFO::main: Logging initialized @985ms to org.eclipse.jetty.util.log.StdErrLog
Mär 05 10:13:19 www java[1083]: 2018-03-05 10:13:19.656:INFO:oejs.Server:main: jetty-9.4.8.v20171121, build timestamp: 2017-11-21T22:27:37+01:00, git hash: 82b8fb23f757335bb3329d540ce37a2a2615f0a8
....
Mär 05 10:13:20 www java[1083]: 2018-03-05 10:13:20.001:WARN:oeja.AnnotationParser:qtp1500056228-11: javax.servlet.AsyncContext scanned from multiple locations: [jar:file:///usr/share/java/jetty-distribution-9.4.8.v20171121/lib/servlet-api-3.1.jar!/javax/servlet/AsyncContext.class, jar:file:///tmp/jetty-127.0.0.1-8080-ws-servlet-0.1-SNAPSHOT.war-_ws-servlet-0.1-SNAPSHOT-any-7391639757847575545.dir/webapp/WEB-INF/lib/javax.servlet-api-3.1.0.jar!/javax/servlet/AsyncContext.class]
Mär 05 10:13:20 www java[1083]: 2018-03-05 10:13:20.011:WARN:oeja.AnnotationParser:qtp1500056228-11: javax.servlet.AsyncEvent scanned from multiple locations: [jar:file:///usr/share/java/jetty-distribution-9.4.8.v20171121/lib/servlet-api-3.1.jar!/javax/servlet/AsyncEvent.class, jar:file:///tmp/jetty-127.0.0.1-8080-ws-servlet-0.1-SNAPSHOT.war-_ws-servlet-0.1-SNAPSHOT-any-7391639757847575545.dir/webapp/WEB-INF/lib/javax.servlet-api-3.1.0.jar!/javax/servlet/AsyncEvent.class]
....
Mär 05 10:13:20 www java[1083]: 2018-03-05 10:13:20.229:INFO:oejs.Server:main: Started @1884ms

Here the full log: https://gist.github.com/afarber/e91c4670b491e15c6de007b7eb1e306d

Is it a known issue in Jetty 9.4.8.v20171121 or have I done something wrong when compiling my WAR file with the pom.xml file:

<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

    <modelVersion>4.0.0</modelVersion>
    <groupId>de.slova</groupId>
    <artifactId>ws-servlet</artifactId>
    <version>0.1-SNAPSHOT</version>
    <packaging>war</packaging>
    <name>WebSocket Servlet WebApp</name>

    <properties>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
        <maven.compiler.source>1.8</maven.compiler.source>
        <maven.compiler.target>1.8</maven.compiler.target>
        <jetty.version>9.4.8.v20171121</jetty.version>
        <pgsql.version>42.1.4</pgsql.version>
    </properties>

    <dependencies>
        <dependency>
            <groupId>org.eclipse.jetty.websocket</groupId>
            <artifactId>websocket-servlet</artifactId>
            <version>${jetty.version}</version>
        </dependency>
        <dependency>
            <groupId>org.eclipse.jetty</groupId>
            <artifactId>jetty-client</artifactId>
            <version>${jetty.version}</version>
        </dependency>
        <dependency>
            <groupId>org.eclipse.jetty</groupId>
            <artifactId>jetty-util</artifactId>
            <version>${jetty.version}</version>
        </dependency>
        <dependency>
            <groupId>org.eclipse.jetty</groupId>
            <artifactId>jetty-util-ajax</artifactId>
            <version>${jetty.version}</version>
        </dependency>
        <dependency>
            <groupId>org.postgresql</groupId>
            <artifactId>postgresql</artifactId>
            <version>${pgsql.version}</version>
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.eclipse.jetty</groupId>
                <artifactId>jetty-maven-plugin</artifactId>
                <version>${jetty.version}</version>
            </plugin>
        </plugins>
    </build>

</project>

Please give me some hints

Best regards
Alex




_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade 9.4.6.v20170531 -> 9.4.8.v20171121:

Alexander Farber
Nevermind, sorry -

On Mon, Mar 5, 2018 at 10:57 AM, Alexander Farber <[hidden email]> wrote:
> Here the full log: https://gist.github.com/afarber/e91c4670b491e15c6de007b7eb1e306d

I have fixed my problem by adding the following to WAR pom.xml:

    <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>javax.servlet-api</artifactId>
      <version>3.1.0</version>
      <scope>provided</scope>
    </dependency>

As described in the https://www.eclipse.org/jetty/documentation/9.4.x/maven-and-jetty.html

After that the WEB-INF/lib/javax.servlet-api-3.1.0.jar has disappeared from my WAR file contents

Regards
Alex

 

_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users