Secure Connection Failed

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Secure Connection Failed

Lou Degenaro
We are running jetty 9.2.22 embedded in our application that uses log4j for logging.  We are using https with self-cert.  We are getting "Secure Connection Failed" when we try to visit via https.  We've tried both FF and Chrome.  Suggestions as to what might be wrong or how to get more information?  The server logs are silent on this issue. 

Coincidentally, we have a similar server (more or less a clone except on a different box) similarly configured that works fine.

Thanks.
Lou.

_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: Secure Connection Failed

Lou Degenaro
I managed to turn on DEBUG (to console) and see the NPE when attempting to use the https connection. 

Please help.

Thanks.

Lou.

-----

01 Mar 2018 14:12:16,889 DEBUG AbstractEndPoint - J[N/A] T[107] init onClose SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,16/30000,SslConnection}{io=0,kio=-1,kro=-1}
01 Mar 2018 14:12:16,889 DEBUG SslConnection - J[N/A] T[107] init SslConnection@67bde9f9{NEED_WRAP,eio=-1/-1,di=-1} -> HttpConnection@f23af17e[FILLING,DecryptedEndPoint@d3af70c8{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,20/30000,HttpConnection}->SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,16/30000,SslConnection}{io=0,kio=-1,kro=-1}][p=HttpParser{s=START,0 of 0},g=HttpGenerator{s=START},c=HttpChannelOverHttp@204b2e5d{r=0,c=false,a=IDLE,uri=}] fill exit
01 Mar 2018 14:12:16,889 DEBUG HttpConnection - J[N/A] T[107] init
java.lang.RuntimeException: Delegated task threw Exception/Error
    at com.ibm.jsse2.D.z(D.java:324)
    at com.ibm.jsse2.aq.b(aq.java:550)
    at com.ibm.jsse2.aq.a(aq.java:466)
    at com.ibm.jsse2.aq.unwrap(aq.java:353)
    at javax.net.ssl.SSLEngine.unwrap(SSLEngine.java:11)
    at org.eclipse.jetty.io.ssl.SslConnection$DecryptedEndPoint.fill(SslConnection.java:520)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:240)
    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
    at java.lang.Thread.run(Thread.java:785)
Caused by: java.lang.NullPointerException
    at com.ibm.jsse2.K.e(K.java:48)
    at com.ibm.jsse2.r.<init>(r.java:14)
    at com.ibm.jsse2.F.A(F.java:487)
    at com.ibm.jsse2.F.a(F.java:563)
    at com.ibm.jsse2.F.b(F.java:88)
    at com.ibm.jsse2.F.a(F.java:91)
    at com.ibm.jsse2.F.a(F.java:853)
    at com.ibm.jsse2.D.r(D.java:610)
    at com.ibm.jsse2.D$b.a(D$b.java:3)
    at com.ibm.jsse2.D$b.run(D$b.java:1)
    at java.security.AccessController.doPrivileged(AccessController.java:686)
    at com.ibm.jsse2.D$c.run(D$c.java:9)
    at org.eclipse.jetty.io.ssl.SslConnection$DecryptedEndPoint.fill(SslConnection.java:620)
    ... 5 more
01 Mar 2018 14:12:16,890 DEBUG AbstractEndPoint - J[N/A] T[107] init onClose DecryptedEndPoint@d3af70c8{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,21/30000,HttpConnection}->SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,17/30000,SslConnection}{io=0,kio=-1,kro=-1}
01 Mar 2018 14:12:16,890 DEBUG SslConnection - J[N/A] T[107] init SslConnection@67bde9f9{NEED_WRAP,eio=-1/-1,di=-1} -> HttpConnection@f23af17e[FILLING,DecryptedEndPoint@d3af70c8{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,21/30000,HttpConnection}->SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,17/30000,SslConnection}{io=0,kio=-1,kro=-1}][p=HttpParser{s=START,0 of 0},g=HttpGenerator{s=START},c=HttpChannelOverHttp@204b2e5d{r=0,c=false,a=IDLE,uri=}] shutdownOutput: oshut=true, ishut=true


On Thu, Mar 1, 2018 at 6:57 AM, Lou DeGenaro <[hidden email]> wrote:
We are running jetty 9.2.22 embedded in our application that uses log4j for logging.  We are using https with self-cert.  We are getting "Secure Connection Failed" when we try to visit via https.  We've tried both FF and Chrome.  Suggestions as to what might be wrong or how to get more information?  The server logs are silent on this issue. 

Coincidentally, we have a similar server (more or less a clone except on a different box) similarly configured that works fine.

Thanks.
Lou.


_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: Secure Connection Failed

Joakim Erdfelt-8
Use Oracle OpenJDK JVM (JRE or JDK).

We don't build with/test on/support the IBM JVM.

From the stacktrace, we can see that the IBM jvm is having some kind of mysterious issue with the SSL/TLS, but the IBM JVM has obfuscated all of their classes making troubleshooting near impossible if you are not IBM.

Joakim Erdfelt / [hidden email]

On Thu, Mar 1, 2018 at 1:20 PM, Lou DeGenaro <[hidden email]> wrote:
I managed to turn on DEBUG (to console) and see the NPE when attempting to use the https connection. 

Please help.

Thanks.

Lou.

-----

01 Mar 2018 14:12:16,889 DEBUG AbstractEndPoint - J[N/A] T[107] init onClose SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,16/30000,SslConnection}{io=0,kio=-1,kro=-1}
01 Mar 2018 14:12:16,889 DEBUG SslConnection - J[N/A] T[107] init SslConnection@67bde9f9{NEED_WRAP,eio=-1/-1,di=-1} -> HttpConnection@f23af17e[FILLING,DecryptedEndPoint@d3af70c8{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,20/30000,HttpConnection}->SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,16/30000,SslConnection}{io=0,kio=-1,kro=-1}][p=HttpParser{s=START,0 of 0},g=HttpGenerator{s=START},c=HttpChannelOverHttp@204b2e5d{r=0,c=false,a=IDLE,uri=}] fill exit
01 Mar 2018 14:12:16,889 DEBUG HttpConnection - J[N/A] T[107] init
java.lang.RuntimeException: Delegated task threw Exception/Error
    at com.ibm.jsse2.D.z(D.java:324)
    at com.ibm.jsse2.aq.b(aq.java:550)
    at com.ibm.jsse2.aq.a(aq.java:466)
    at com.ibm.jsse2.aq.unwrap(aq.java:353)
    at javax.net.ssl.SSLEngine.unwrap(SSLEngine.java:11)
    at org.eclipse.jetty.io.ssl.SslConnection$DecryptedEndPoint.fill(SslConnection.java:520)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:240)
    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
    at java.lang.Thread.run(Thread.java:785)
Caused by: java.lang.NullPointerException
    at com.ibm.jsse2.K.e(K.java:48)
    at com.ibm.jsse2.r.<init>(r.java:14)
    at com.ibm.jsse2.F.A(F.java:487)
    at com.ibm.jsse2.F.a(F.java:563)
    at com.ibm.jsse2.F.b(F.java:88)
    at com.ibm.jsse2.F.a(F.java:91)
    at com.ibm.jsse2.F.a(F.java:853)
    at com.ibm.jsse2.D.r(D.java:610)
    at com.ibm.jsse2.D$b.a(D$b.java:3)
    at com.ibm.jsse2.D$b.run(D$b.java:1)
    at java.security.AccessController.doPrivileged(AccessController.java:686)
    at com.ibm.jsse2.D$c.run(D$c.java:9)
    at org.eclipse.jetty.io.ssl.SslConnection$DecryptedEndPoint.fill(SslConnection.java:620)
    ... 5 more
01 Mar 2018 14:12:16,890 DEBUG AbstractEndPoint - J[N/A] T[107] init onClose DecryptedEndPoint@d3af70c8{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,21/30000,HttpConnection}->SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,17/30000,SslConnection}{io=0,kio=-1,kro=-1}
01 Mar 2018 14:12:16,890 DEBUG SslConnection - J[N/A] T[107] init SslConnection@67bde9f9{NEED_WRAP,eio=-1/-1,di=-1} -> HttpConnection@f23af17e[FILLING,DecryptedEndPoint@d3af70c8{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,21/30000,HttpConnection}->SelectChannelEndPoint@ddbefc0a{/10.199.198.6:53962<->42155,CLOSED,ISHUT,OSHUT,-,-,17/30000,SslConnection}{io=0,kio=-1,kro=-1}][p=HttpParser{s=START,0 of 0},g=HttpGenerator{s=START},c=HttpChannelOverHttp@204b2e5d{r=0,c=false,a=IDLE,uri=}] shutdownOutput: oshut=true, ishut=true


On Thu, Mar 1, 2018 at 6:57 AM, Lou DeGenaro <[hidden email]> wrote:
We are running jetty 9.2.22 embedded in our application that uses log4j for logging.  We are using https with self-cert.  We are getting "Secure Connection Failed" when we try to visit via https.  We've tried both FF and Chrome.  Suggestions as to what might be wrong or how to get more information?  The server logs are silent on this issue. 

Coincidentally, we have a similar server (more or less a clone except on a different box) similarly configured that works fine.

Thanks.
Lou.


_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users


_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users