Problems with loading JSF based war file

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems with loading JSF based war file

Ikonne, Ike

Hi all,

 

I have a JSF web application; I loaded it dynamically with Jetty using the following piece of code

 

wac = new WebAppContext();

wac.setContextPath("/myapp/*");

wac.setWar(file.getAbsolutePath());

 

 

g.mortbay.log - Holding class javax.faces.webapp.FacesServlet

 [main] DEBUG org.mortbay.log - loaded class javax.servlet.ServletException

[main] DEBUG org.mortbay.log - loaded class javax.servlet.ServletException from

[hidden email]

[main] DEBUG org.mortbay.log - loaded interface javax.servlet.ServletConfig

 [main] DEBUG org.mortbay.log - loaded interface javax.servlet.ServletConfig from

[hidden email]

 [main] DEBUG com.sun.faces.lifecycle.LifecycleFactoryImpl - getLifecycle: DEFAULT

[hidden email]

 [main] DEBUG org.mortbay.log - started Faces Servlet

 [main] DEBUG org.mortbay.log - started

[hidden email]

 [main] DEBUG org.mortbay.log - starting HandlerCollection@1536eec

 [main] DEBUG org.mortbay.log - started HandlerCollection@1536eec

 [main] DEBUG org.mortbay.log - starting Server@a36b53

 

It looks like jetty loaded the war successfully, but when I try to access the webapplication

http://localhost:8080/myapp/  jetty could not find the context, instead, it was looking for my app

at:

 

REQUEST /myapp/ on [hidden email]

 [btpool0-2 - /mapp/] DEBUG org.mortbay.log - servlet=org.mortbay.jetty.servlet.DefaultServlet

[btpool0-2 - /myapp/] DEBUG org.mortbay.log - chain=null

 [btpool0-2 - / myapp /] DEBUG org.mortbay.log - servelet holder=org.mortbay.jetty.servlet.DefaultServlet

 [btpool0-2 - / myapp /] DEBUG org.mortbay.log - started [hidden email]

 [btpool0-2 - / myapp /] DEBUG org.mortbay.log - resource base = file:/C:/development/sspconfigurator-04122007/dist/conf/jetty/docroot/

[btpool0-2 - / myapp /] DEBUG org.mortbay.log - lookup /myapp/

 [btpool0-2 - / myapp /] DEBUG org.mortbay.log - CACHE MISS: /myapp/

 [btpool0-2 - / myapp /] DEBUG org.mortbay.log - resource=null

 [btpool0-2 - / myapp/] DEBUG org.mortbay.log - RESPONSE /myapp/  404

 

 

What am I missing or doing wrong? 

 

 

Thanks,

 

Ike

 

 

 

 

 

 


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Jetty-support mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jetty-support