Not running on Jetty, JSR-356 support unavailable

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Not running on Jetty, JSR-356 support unavailable

Naveen Kumar
Hi All,

I am trying to upgrade ActiveMQ jar to its latest version. It requires me
to upgrade Jetty to 9.4 version.
I have current setup as Tomcat 9 + ActiveMQ 5.12 + jetty-all-8.1.
I want to upgrade it as Tomcat 9 + ActiveMQ 5.15 + jetty-all-9.4.19.v20190610-uber.

After putting the jetty jar in tomcat when I try to start it gives me below error:

javax.servlet.ServletException: Not running on Jetty, JSR-356 support
unavailable
    at
org.eclipse.jetty.websocket.jsr356.server.deploy.WebSocketServerContainerInitializer.onStartup(WebSocketServerContainerInitializer.java:200)
    at
org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5125)

It looks like Jetty 9.4 has JSR-356 implementation and it is conflicting with Tomcat.
I do not need websockets.
Can someone please help to fix this ?

Thanks
Naveen

_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: Not running on Jetty, JSR-356 support unavailable

Peter Boughton
The jetty-all/uber Jar is not meant to be used by other projects - see
https://www.eclipse.org/lists/jetty-users/msg06030.html


 > I am trying to upgrade ActiveMQ jar to its latest version.
 > It requires me to upgrade Jetty to 9.4 version.

How does it convey this requirement? It may clarify which jar(s) are
actually needed, otherwise you may need to ask the ActiveMQ project to
clarify their dependencies.

And it looks like you've already posted the same message on the ActiveMQ
mailing list:
http://activemq.2283324.n4.nabble.com/Not-running-on-Jetty-JSR-356-support-unavailable-td4753568.html

When cross-posting like this, it's polite to reference other messages so
that people don't waste time repeating what may have been said elsewhere
(it also helps others with similar issues to find the solution).
_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/jetty-users