Jetty is Hanging

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Jetty is Hanging

IcedDante
This post has NOT been accepted by the mailing list yet.
I'm a Jetty newb that is having a lot of problems. I am running Jetty from the console. I started off importing a sample Tapestry project and was able to run it fine... the project is on the Tapestry page and is called tutorial1

I began work on my own project then and began introducing new functionality to it incrementally allowing Jetty to pick up the changes and test it as I went along. At some point it stopped working. I tried backtracking my project to get it to a working state but every time I requested the home page it would just hang. At this point I still thought it was my fault via some Tapestry/Hibernate error, though I did think a more graceful error message would have been nice than the it attempting to load for a minute followed by a server timeout error.

I then shutdown jetty and attempted to load up the imported sample project I first tried using mvn jetty:run in my tutorial1 project directory. it doesn't work either! When I try going to localhost:8080/tutorial1 or the URL of my project the jetty console does show any output, almost as if it's not receiving the request.

I rebooted my entire machine but that doesn't help. I am not familiar with jetty architecture and am unsure if there is a way I can purge all my files from the jetty web application directory.

Any ideas?

I start jetty with: mvn jetty:run
My pom.xml is configured for a 5 second interval for checking on changes
I stop jetty wtih Ctrl+C

I attempted clean with mvn clean and mvn clean jetty:run

This is the pom plugin definition for the projects:
            <plugin>
                <groupId>org.mortbay.jetty</groupId>
                <artifactId>maven-jetty-plugin</artifactId>
                <version>6.1.16</version>
                <configuration>
                <scanIntervalSeconds>5</scanIntervalSeconds>
                   
                    <requestLog implementation="org.mortbay.jetty.NCSARequestLog">
                       
                        <append>true</append>
                    </requestLog>
                    <systemProperties>
                        <systemProperty>
                            <name>tapestry.execution-mode</name>
                            <value>development</value>
                        </systemProperty>
                    </systemProperties>
                </configuration>
            </plugin>