Jetty 9.4.14 set forwarded true for HTTPS

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Jetty 9.4.14 set forwarded true for HTTPS

Kapil
Hi,

Earlier I was using Jetty 8 and after setting property forwared=true for Configuring mod_proxy_http, please refer - https://wiki.eclipse.org/Jetty/Tutorial/Apache

Now in Jetty 9.4, the server doesnt start as the class SelectChannelConnector is not present, please let me know how to get it work on Jetty 9.4.

Thank you
Kapil

_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/jetty-users
Reply | Threaded
Open this post in threaded view
|

Re: Jetty 9.4.14 set forwarded true for HTTPS

Kapil
Got it working after adding below changes in httpConfig:
<Call name="addCustomizer">
    <Arg><New class="org.eclipse.jetty.server.ForwardedRequestCustomizer"/></Arg>
  </Call>

On Wed, Dec 19, 2018 at 2:15 PM kapil gupta <[hidden email]> wrote:
Hi,

Earlier I was using Jetty 8 and after setting property forwared=true for Configuring mod_proxy_http, please refer - https://wiki.eclipse.org/Jetty/Tutorial/Apache

Now in Jetty 9.4, the server doesnt start as the class SelectChannelConnector is not present, please let me know how to get it work on Jetty 9.4.

Thank you
Kapil

_______________________________________________
jetty-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/jetty-users