Jetty 8.1.1+ and JSP 2.2

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Jetty 8.1.1+ and JSP 2.2

kalgon
This post has NOT been accepted by the mailing list yet.
Hi,

I've been trying to use JSP (xml) 2.2 with jetty-maven-plugin 8.1.3 but it doesn't seem to support it. When my JSP starts with [jsp:root version="2.2" xmlns:jsp="..."], I get an exception saying only versions 1.0, 2.0 and 2.1 are supported. I've also noticed that org.glassfish.web:jsp-impl:2.2.2-b06 and javax.servlet.jsp:jsp-api:2.2 dependencies are commented out in the jetty-maven-plugin pom since 8.1.1. I'd like to use JSP 2.2 because I've heard its EL allows to call methods with parameters.

Thanks,

Xavier