Jetty 6.1.5 Release

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Jetty 6.1.5 Release

jan_bartel
Jetty Release 6.1.5 is now available via http://jetty.mortbay.org

This release is *only* available from Codehaus and the Jetty site.
See:

   http://docs.codehaus.org/display/JETTY/Downloading+and+Installing

The release includes a few minor fixes and some good improvements
and a few new features, including: RPMs, OSGi, graceful shutdown
and a new gzip filter.

The ant module jar, rpms and jboss sar are also available for
download.


jetty-6.1.5 - 19 Jul 2007
 + Fixed GzipFilter for dispatchers
 + Fixed reset of reason
 + JETTY-392 - updated LikeJettyXml example

jetty-6.1.5rc0 - 15 Jul 200
 + update terracotta session clustering to terracotta 2.4
 + SetUID option to only open connectors before setUID.
 + Protect SslSelectChannelConnector from exceptions during close
 + Improved Request log configuration options
 + Added GzipFilter and UserAgentFilter
 + make OSGi manifests for jetty jars
 + update terracotta configs for tc 2.4 stable1
 + remove call to open connectors in jetty.xml
 + update links on website
 + make jetty plus example webapps use ContextDeployer
 + Dispatch SslEngine expiry (non atomic)
 + Make SLF4JLog impl public, add mbean descriptors
 + SPR-3682 - dont hide forward attr in include.
 + Upgrade to Jasper 2.1 tag SJSAS-9_1-B50G-BETA3-27_June_2007
 + JETTY-253 - Improved graceful shutdown
 + JETTY-373 - Stop all dependent lifecycles
 + JETTY-374 - HttpTesters handles large requests/responses
 + JETTY-375 - IllegalStateException when committed.
 + JETTY-376 - allow spaces in reason string
 + JETTY-377 - allow sessions to be wrapped with AbstractSesssionManager.SessionIf
 + JETTY-378 - handle JVMs with non ISO/UTF default encodings
 + JETTY-380 - handle pipelines of more than 4 requests!
 + JETTY-385 - EncodeURL for new sessions from dispatch
 + JETTY-386 - Allow // in file resources


-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Jetty-announce mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jetty-announce
Reply | Threaded
Open this post in threaded view
|

SSL Doesn't Work in Jetty 6.1.5 + TerraCotta 2.4

swordfish
I've tried Jetty 6.1.5 with TerraCotta 2.4.  The HTTP works well, however the HTTPS doesn't.  It throws an exeception due to verified error.  The command I run is: java -Xbootclasspath/p:/usr/local/terracotta/lib/dso-boot/dso-boot-hotspot_linux_150_11.jar -Dtc.install-root=/usr/local/terracotta -Dtc.config=192.168.0.2:9510 -jar ./start.jar ./contrib/terracotta/src/main/resources/jetty.xml (the current directory for running this is /usr/local/jetty-6.1.5, and I have copied the SSL connector XML content from jetty-ssl.xml to this jetty.xml).

It looks like the running parameter -Xbootclasspath/p:/usr/local/terracotta/lib/dso-boot/dso-boot-hotspot_linux_150_11.jar causes this problem.  Without this parameter, Jett can startup on both 80 and 443 ports normally.

Does dso-boot-hotspot_linux_150_11.jar have to be signed by the keystore used in SSL connector?  Have you tested the SSL against this release?  Please kindly advise.  Thanks.