How to embedd Jetty 8.0?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

How to embedd Jetty 8.0?

Uday Subbarayan-3
Hi All,
     I need to develop a small MQ client embedding Jetty inside. I would like to use Jetty 8 for Servlet 3 features. I understand from the tutorial that I need only 2 jars.

a)I downloaded "jetty-all-8.1.2.v20120308.jar" from here:

b)Then I downloaded Jetty 8 distribution from here:
I see that "servlet-api-3.0.jar" is inside the lib folder.

I am going to [a] & [b] to build my application. Is this correct?

The reason  I am asking is that I don't see servlet-api-3.0 jar here. (all are in alpha)

Thanks,
-Uday.
Reply | Threaded
Open this post in threaded view
|

Re: How to embedd Jetty 8.0?

Jesse McConnell
http://wiki.eclipse.org/Jetty/Tutorial/Embedding_Jetty

enjoy!
jesse

--
jesse mcconnell
[hidden email]



On Fri, Mar 16, 2012 at 17:30, Uday Subbarayan
<[hidden email]> wrote:

> Hi All,
>      I need to develop a small MQ client embedding Jetty inside. I would
> like to use Jetty 8 for Servlet 3 features. I understand from the tutorial
> that I need only 2 jars.
>
> a)I downloaded "jetty-all-8.1.2.v20120308.jar" from here:
> http://repo1.maven.org/maven2/org/eclipse/jetty/aggregate/jetty-all/8.1.2.v20120308/
>
> b)Then I downloaded Jetty 8 distribution from here:
> http://download.eclipse.org/jetty/stable-8/dist/
> I see that "servlet-api-3.0.jar" is inside the lib folder.
>
> I am going to [a] & [b] to build my application. Is this correct?
>
> The reason  I am asking is that I don't see servlet-api-3.0 jar here. (all
> are in alpha)
> http://repo1.maven.org/maven2/javax/servlet/servlet-api/
>
> Thanks,
> -Uday.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: How to embedd Jetty 8.0?

Uday Subbarayan-3
Yes, I read the tutorial. 

I am just checking for the compatibility of 2 jars and I am downloading it from correct place. 

Also, Is servlet-api-3.0.jar is a stable one to use in production?

Best,
-Uday.


From: Jesse McConnell <[hidden email]>
To: [hidden email]
Sent: Friday, March 16, 2012 3:34 PM
Subject: Re: [jetty-user] How to embedd Jetty 8.0?

http://wiki.eclipse.org/Jetty/Tutorial/Embedding_Jetty

enjoy!
jesse

--
jesse mcconnell
[hidden email]



On Fri, Mar 16, 2012 at 17:30, Uday Subbarayan
<[hidden email]> wrote:

> Hi All,
>      I need to develop a small MQ client embedding Jetty inside. I would
> like to use Jetty 8 for Servlet 3 features. I understand from the tutorial
> that I need only 2 jars.
>
> a)I downloaded "jetty-all-8.1.2.v20120308.jar" from here:
> http://repo1.maven.org/maven2/org/eclipse/jetty/aggregate/jetty-all/8.1.2.v20120308/
>
> b)Then I downloaded Jetty 8 distribution from here:
> http://download.eclipse.org/jetty/stable-8/dist/
> I see that "servlet-api-3.0.jar" is inside the lib folder.
>
> I am going to [a] & [b] to build my application. Is this correct?
>
> The reason  I am asking is that I don't see servlet-api-3.0 jar here. (all
> are in alpha)
> http://repo1.maven.org/maven2/javax/servlet/servlet-api/
>
> Thanks,
> -Uday.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email




Reply | Threaded
Open this post in threaded view
|

Re: How to embedd Jetty 8.0?

Jesse McConnell
This is the one we are using in our build now, but that is mainly
because it is signed by eclipse

http://repo2.maven.org/maven2/org/eclipse/jetty/orbit/javax.servlet/3.0.0.v201112011016/

servlet 3.0 is a stable released jar at this point though

jesse

--
jesse mcconnell
[hidden email]



On Fri, Mar 16, 2012 at 18:32, Uday Subbarayan
<[hidden email]> wrote:

> Yes, I read the tutorial.
>
> I am just checking for the compatibility of 2 jars and I am downloading it
> from correct place.
>
> Also, Is servlet-api-3.0.jar is a stable one to use in production?
>
> Best,
> -Uday.
>
> ________________________________
> From: Jesse McConnell <[hidden email]>
> To: [hidden email]
> Sent: Friday, March 16, 2012 3:34 PM
> Subject: Re: [jetty-user] How to embedd Jetty 8.0?
>
> http://wiki.eclipse.org/Jetty/Tutorial/Embedding_Jetty
>
> enjoy!
> jesse
>
> --
> jesse mcconnell
> [hidden email]
>
>
>
> On Fri, Mar 16, 2012 at 17:30, Uday Subbarayan
> <[hidden email]> wrote:
>> Hi All,
>>      I need to develop a small MQ client embedding Jetty inside. I would
>> like to use Jetty 8 for Servlet 3 features. I understand from the tutorial
>> that I need only 2 jars.
>>
>> a)I downloaded "jetty-all-8.1.2.v20120308.jar" from here:
>>
>> http://repo1.maven.org/maven2/org/eclipse/jetty/aggregate/jetty-all/8.1.2.v20120308/
>>
>> b)Then I downloaded Jetty 8 distribution from here:
>> http://download.eclipse.org/jetty/stable-8/dist/
>> I see that "servlet-api-3.0.jar" is inside the lib folder.
>>
>> I am going to [a] & [b] to build my application. Is this correct?
>>
>> The reason  I am asking is that I don't see servlet-api-3.0 jar here. (all
>> are in alpha)
>> http://repo1.maven.org/maven2/javax/servlet/servlet-api/
>>
>> Thanks,
>> -Uday.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: How to embedd Jetty 8.0?

Uday Subbarayan-3
Thanks for the quick response. 

Best,
-Uday.


From: Jesse McConnell <[hidden email]>
To: [hidden email]
Sent: Friday, March 16, 2012 4:54 PM
Subject: Re: [jetty-user] How to embedd Jetty 8.0?

This is the one we are using in our build now, but that is mainly
because it is signed by eclipse

http://repo2.maven.org/maven2/org/eclipse/jetty/orbit/javax.servlet/3.0.0.v201112011016/

servlet 3.0 is a stable released jar at this point though

jesse

--
jesse mcconnell
[hidden email]



On Fri, Mar 16, 2012 at 18:32, Uday Subbarayan
<[hidden email]> wrote:

> Yes, I read the tutorial.
>
> I am just checking for the compatibility of 2 jars and I am downloading it
> from correct place.
>
> Also, Is servlet-api-3.0.jar is a stable one to use in production?
>
> Best,
> -Uday.
>
> ________________________________
> From: Jesse McConnell <[hidden email]>
> To: [hidden email]
> Sent: Friday, March 16, 2012 3:34 PM
> Subject: Re: [jetty-user] How to embedd Jetty 8.0?
>
> http://wiki.eclipse.org/Jetty/Tutorial/Embedding_Jetty
>
> enjoy!
> jesse
>
> --
> jesse mcconnell
> [hidden email]
>
>
>
> On Fri, Mar 16, 2012 at 17:30, Uday Subbarayan
> <[hidden email]> wrote:
>> Hi All,
>>      I need to develop a small MQ client embedding Jetty inside. I would
>> like to use Jetty 8 for Servlet 3 features. I understand from the tutorial
>> that I need only 2 jars.
>>
>> a)I downloaded "jetty-all-8.1.2.v20120308.jar" from here:
>>
>> http://repo1.maven.org/maven2/org/eclipse/jetty/aggregate/jetty-all/8.1.2.v20120308/
>>
>> b)Then I downloaded Jetty 8 distribution from here:
>> http://download.eclipse.org/jetty/stable-8/dist/
>> I see that "servlet-api-3.0.jar" is inside the lib folder.
>>
>> I am going to [a] & [b] to build my application. Is this correct?
>>
>> The reason  I am asking is that I don't see servlet-api-3.0 jar here. (all
>> are in alpha)
>> http://repo1.maven.org/maven2/javax/servlet/servlet-api/
>>
>> Thanks,
>> -Uday.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email